MainWP Community

Advanced Uptime Monitor Extension

Hi there, I’ve installed and activated the Advanced Uptime Monitor Extension.
But besides the API key I can’t add anything.
The field for the Default alert contact is empty and can’t be anything added.
Then I get the alert “Unable to load Uptime monitor data”, but on settings when I click on “reload uptime robot data” it shows success.
I can’t add any pages.
Where can the problem be?
Thank’ for any advise

Hi @Frank, can you please verify that your Uptime Robot API key is correct. If you check your Uptime Robot account, please find the API key and see if it’s the one that you have saved in the extension settings.

I did check and even ordered another new API key. Then I deleted the active key (under extensions" and added and activated the new key. But same story. No adding of “Default alert contact” possible. No “Timezone” is shown. it also shows “Unable to load Uptime monitor data”

Can you grab a screenshot of the extensions settings page and send it to me via private messsage?

done and inboxed you

Thanks, I replied.

Noticed that the API key is not correct. You saved your extension API key by accident in the Uptime Robot API key field. In the Uptime Robot Settings, you need to save API key provided by Uptime Robot, here is how you can generate it: https://mainwp.com/help/docs/create-uptime-robot-api-key/

Thanks I saw it, my bad. But I also got the new API from Uptime Robot and now mainwp says “Activation error! Matching API key could not be found.” with the new API key from uptime robot

never mind, got the issue, you don’t need to add under extensions but directly on the extension itselfs. then it works. thanks for your help

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.