Disconnected sites

All of a sudden 9 out of 26 sites has been disconnected.

Stuff I tried without result

  • reconnecting
  • inactivate and re-activate the plugin
  • remove and re-install plugin
  • remove and re-add site
  • remove all other plugins

These sites are spread over multiple hosts, so nothing made server-side that would cause this since other sites on same host still works

How do I get back on track…?!?

Hi Nicklas,

Can you please tell us what response do you get if you try to reconnect sites?

MainWP Child plugin not detected. First, install and activate the plugin and add your site to your MainWP Dashboard afterward. If you continue experiencing this issue, check the child site for known plugin conflicts, or check the MainWP Community for help.

I do cron every hour to check for updates, last sync varies from Sep 28 to Oct 2.

Hi Nicklas,

Thanks for the feedback.

Do you use Cloudflare or any other cloud-proxy firewall?
Do you use some Security plugins on the disconnected sites?

Have you checked the list of Potential Issues?

Just as sudden most sites are back in controlpanel, two are still disconnected

No CF and no security-plugins that could cause problems

The potential issues-page didn’t help much either. Of course it could be the server blocking calls to the site(s) specifically, but I doubt it. I guess most blocks are set server-wide.

I’ll try to migrate the MainWP Dashboard-site to a VPS and see if that helps

This is actually one of the most common reasons that I have seen. Please make sure that your Dashboard IP is whitelisted in child site server firewall.

Let us know how it goes after moving the dashboard.

1 Like