MainWP Community

Google Analytics Extension Issues Says App needs to be Verified

Ugh it has taken me a while to get the Analytics Extension to work, I think I am almost there.

I have the OAuth app setup but it says “Disconnected” in the Manage Accounts page for the MainWP Google Analytics Extension.

When I connect the account Google then asks me to choose an account to continue. I choose my account and then I get a warning screen that says:

Google hasn’t verified this app

The app is requesting access to sensitive info in your Google Account. Until the developer (this is my email address) verifies this app with Google, you shouldn’t use it.

If you’re the developer, submit a verification request to remove this screen. Learn more

[Advanced]

If I click on the Advanced button it says:

Continue only if you understand the risks and trust the developer (my email here).

Go to mywebsite.com (unsafe)

If I click the go to my website button it just takes me back to my website frontend.

I have verified my domain already by using the file in the root of my website (it is on a sub domain) but it says I now have to verified the app? This is the link they give: https://support.google.com/cloud/answer/7454865

I think I must have missed something when creating the Credentials. Can someone help or do I really need to go through the process of verifying the app when it appears no one else has.

Thanks

Tom

The App doesn’t “need” to be verified technically since it’s an “in house application” - The only time this requests has come up during testing is when a Business Logo is added to the app. For some reason this bugs their script out during setup. It should read like this:

Here is the [LEAR MORE} link https://support.google.com/cloud/answer/9110914

You most likely just need to finish the OAuth Consent Screen.

Try to follow these directions here to a T & ONLY fill out what we have in the screen shots - if you still have issue let us know on what step you are having a problem so we can follow along…

So I double checked the Consent Screen and it looked like it does in the docs.

In my htaccess I do have some text to stop hotlinking of assets so I removed that (I still left in my htpasswd stuff).

I don’t have a logo enabled and I do have “Verification not Required” but for some reason during the Connection process with MainWP I get the “Google App has not been Verified” message. Anyways I continued on and it worked this time so it must have been the Hotlinking in the htaccess.

I should only have to do this login process once correct? (as long as my account has access to my clients Analytics)

Also not being verified shouldn’t affect anything else with the app?

BTW I still can’t connect the property properly to the site. I edited the site in MainWP and it is not in the dropdown list of properties (others are). I had the same issue in RankMath and that was because it doesn’t support Google Analytics V4. Is this the same for MainWP?

This is a new site so it automatically created the account using V4. What a pain it has been. I can’t seem to find a way to migrate the v4 account to V3.

Okay I got it working by scrapping the Google Analytics 4 Property and then recreating it as a 3.

You have to go under the advanced options when creating the property to do this. For more details see: https://support.google.com/analytics/thread/78494933?hl=en

Still I guess it should be noted that MainWP doesn’t support Google Analytics 4 Properties.

Also still have the Verification message but still got it to work. I should only need the one account right so no other users should see this Verification warning?

Also having the Verification warning shouldn’t affect how the app works right?

Just want to confirm this?

Also is Google Analytics 4 support in the roadmap somewhere?