MainWP Community

Invalid Host (WebGo)

Hello together,

I installed the Dashboard in an extra wordpress installation.

Now I want to connect my first child. I installed the child okugin and activate it.

Now always when I try to connect the site the Error “Invalid Host” occured".
What could be the reason? What could I try?

My Webhoste is WebGo and I have a virtual server there.

Thanks for all
Greetings
Chris

Hi @DuerrSteidle, do you get this problem with only that one child site or with any child site that you try to connect? Have you tried with some child site that is hosted on a different server?

I have the problem with every child.

And I’m not able to test another server becaus I only have this one.

Server Info Required Detected Status

MainWP Dashboard
MainWP Dashboard Version 4.0.7.1 4.0.7.1 Bestanden
MainWP Upload Directory Writable Writable Bestanden
MainWP-Erweiterungen
Keine installierten Erweiterungen
WordPress
WordPress Version >=3.6 5.3.2 Bestanden
WordPress Memory Limit >=64M 32M Warnung
MultiSite Disabled =true true Bestanden
Dateisystem-Methode = direct direct Pass
PHP
PHP Version >=5.6 7.3.13-1+0~20191218.50+debian9~1.gbp23c2da Bestanden
PHP Safe Mode Disabled =true true Bestanden
PHP Max Execution Time >=30 seconds 30 Bestanden
PHP Max Input Time >=30 seconds 60 Bestanden
PHP Memory Limit >=128M 32M Warnung
PCRE Backtracking Limit >=10000 1000000 Bestanden
PHP Upload Max Filesize >=2M 32M Bestanden
PHP Post Max Size >=2M 16M Bestanden
SSL Extension Enabled =true true Bestanden
SSL Warnings = empty Bestanden
cURL Extension Enabled =true true Bestanden
cURL Timeout >=300 seconds 60 Warnung
cURL Version >=7.18.1 7.52.1 Bestanden
cURL SSL Version >=OpenSSL/0.9.8l OpenSSL/1.0.2u Bestanden
PHP Allow URL fopen NEIN
PHP unterstützt Exif JA ( V7.3.)
PHP unterstützt IPTC JA
PHP unterstützt XML JA
PHP Deaktivierte Funktionen curl_exec, curl_multi_exec, exec, parse_ini_file, passthru, popen, proc_close, proc_get_status, proc_nice, proc_open, proc_terminate, shell_exec, show_source, system,
PHP Geladene Erweiterungen Core, PDO, PDO_Firebird, PDO_ODBC, Phar, Reflection, SPL, SimpleXML, Zend OPcache, apc, apcu, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dba, dom, enchant, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imagick, imap, interbase, intl, json, ldap, libxml, mbstring, mysqli, mysqlnd, odbc, openssl, pcre, pdo_dblib, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, posix, pspell, readline, recode, session, shmop, snmp, soap, sockets, sodium, sqlite3, standard, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib
MySQL
MySQL Version >=5.0 10.3.21-MariaDB-1:10.3.21+maria~stretch-log Bestanden
MySQL-Modus NOT SET
MySQL Client Verschlüsselung utf8mb4
Server Info
Server-Software Apache
Betriebssystem Linux
Architektur 64 bit
Server-Protokoll HTTP/1.1
HTTPS AN - on
Verbindung zum Server selbst Unerwarteter HTTP response body:
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36
Geteway-Schnittstelle CGI/1.1
Arbeitsspeicherauslastung 17.56 MB
Antwortzeit 1580735345
Inhalt akzeptieren text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,/;q=0.8,application/signed-exchange;v=b3;q=0.9
Zeichensatz des Inhalts n. a.
MainWP-Einstellungen
Anzahl Child-Websites 0
WP-Cron benutzen No
Für Shared Hosting oder große Netzwerke optimierenYes
Automatische tägliche AktualisierungInstall trusted updates
Aufgegebene Plugins/Themes-Toleranz
Maximale Anzahl der Beiträge, die zurückgegeben werden sollen
Maximale Anzahl der Seiten, die zurückgegeben werden sollen
Vorrangiges Backup-System Standard MainWP Backups
Maximale gleichzeitige Anfragen 4
Minimale Verzögerung zwischen Anfragen200
Maximale gleichzeitige Anfragen pro IP1
Minimale Verzögerung zwischen Anfragen zu derselben IP1000
Maximale gleichzeitige Synchronisierungs-Anfragen
Minimale gleichzeitige Installieren/Aktualisieren-Anfragen
Active Plugins
Akismet Anti-Spam 4.1.3 Inaktiv
Hello Dolly 1.7.2 Inaktiv
MainWP Dashboard 4.0.7.1 Aktiviert

Can somebody help me? I dont know what to do…

@DuerrSteidle, it seems that the loopback connections are dissabled on your server. See here:

image

This means that sites on the server cannot communicate between each other.

Can you contact your host support and have enable the loopback connections? It can also be that some server-side security rule is causing this problem and blocking self-connect request. They should be able to identify this.

Please let us know how it goes.

They didn’t find anything that could help me.

WebGo: We have no blockades in this respect. Connections should be possible without problems.
I: And what about loopback connections?
WebGo: That shouldn’t be an obstacle either. Connections to 127.0.0.1 are possible without problems.
I: Have you already tried MainWp on your servers?
WebGo: Unfortunately not. We have absolutely no experience with it.
I: I just get the following error message
“HTTPS ON - on
Connection to the server itself Unexpected HTTP response body:”
I: I want to add test01.de as a child to the dashboard running on mainwp.test02.com
WebGo: Unfortunately, I wouldn’t know how to approach this. Unfortunately we are no Wordpress experts and can’t or only partially help with special Wordpress questions. We recommend to ask the Wordpress Community because they know exactly what to do.
Alternatively the developer should be able to help. Many plugin- or theme-developers help here extensively and make server-settings for you if necessary. But of course you have to ask there.
I’m sorry that I can’t help more exactly.

Should I directly contact the serveice from mainWP?

Is there some security plugin that you have on all your sites?

No all sites are clear of all.
MainWP is the first installed plugin on both sites.

Do you have some custom security rules in .htaccess?
Do you use some cloud proxy firewall such as Cloudflare or Sucuri?
Can you please contact your host support again and have them double check the server firewall and mod_Security?
What response do you get if you try the Test Connection feature and test one of your sites?

The following code stand in .htaccess

# BEGIN WordPress
# Die Anweisungen (Zeilen) zwischen `BEGIN WordPress` und `END WordPress` sind
# dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
# Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

I just have no other installation on wordPress.

MainWp Dashboard and MainWP Child are the only plugins which I installed.

The mesaage I got by “Try Connection” named

Connection test failed.
Error message: Invalid host.

@DuerrSteidle Since you got that error I have checked your DNS Records out. They all come back blank on tests like these:

https://www.whatsmydns.net/#A/test01.de


https://www.dnstester.net/

And a full DNS report does show Names Servers but there is some miss-configuration:

https://mxtoolbox.com/SuperTool.aspx?action=dns:test01.de&newAppVersion=1

When visiting the site it does not resolve. I would look into this as being the main reason that you can not connect.

1 Like

Oh sry I don’t wrote my right domain.

The domain ist ok. I can open it whereever I are.

@DuerrSteidle What is the correct domain for the Child Site you can not connect to?

The domain is www.webmutanten.de

Hi @DuerrSteidle, it may be best if you could open a helpdesk ticket so we can run some more testing and if needed get our developers to check your site.

@DuerrSteidle I didn’t notice a ticket from you, if you submitted one can you please give me the ticket# so I can research it?

I’ve addig a ticket to my Hoster. If there are further problems I’m writing a ticket here.

2 Likes

I solved the problem myself.

I had chosen a provider when I set it up.

Since my site runs on the same server I had to choose localhost.

3 Likes

Thanks for sharing the info. I am glad to see that the problem is solved.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.