iThemes Security Extension Critial Error PHP8

The iThemes Security Extension throws the following critical error with PHP 8:

An error of type E_ERROR was caused in line 499 of the file /www/htdocs/w01af748/xxx/wp-content/plugins/mainwp-ithemes-security-extension/core/admin-pages/page-settings.php. Error message: Uncaught TypeError: implode(): Argument #2 ($array) must be of type ?array, string given in /www/htdocs/w01af748/xxx/wp-content/plugins/mainwp-ithemes-security-extension/core/admin-pages/page-settings.php:499

Hi @mensmaximus,

We have plans to add full support for PHP 8 very soon. However, for now, we still can’t say that MainWP is fully PHP 8 ready.

Here is the discussion about from a few weeks ago: