MainWP Community

MainWP Child Reports plugin doesn't activate due to missing dBase tables

On one of the maintenance sites the plugin MainWP Child is connecting to my Dashboard, however the MainWP Child Reports plugin is installed, it can’t be activated due to error:
The following tables are not present in the WordPress database:
wp_mainwp_stream, wp_mainwp_stream_meta
Please uninstall the Reports plugin and activate it again.
I tried this several times and it will not activate. Any fixes?
Site is completely up-to-date theme, plugins and WP.
Thanks for help

Hi @Suzan_SKS, do you get this error on any other site? Do you get the same if you temporarily deactivate all other plugins? Do you see any error in the Error Log on the child site (WP Admin > Settings > MainWP Child > Server Information (error log section at the bottom))?

Hi @bogdan

  • At the day I can’t deactivate all plugins but I did it on the identical local site.
  • Local with all plugins deactivated and child and child reports activated, same problem
    Error log:
    WordPress database error Table ‘local.wp_mainwp_stream’ doesn’t exist for query SHOW FULL COLUMNS FROM wp_mainwp_stream made by activate_plugins, activate_plugin, do_action(‘activate_plugin’), WP_Hook->do_action, WP_Hook->apply_filters, WP_MainWP_Stream\Connector->callback, call_user_func_array, WP_MainWP_Stream\Connector_Installer->callback_activate_plugin, WP_MainWP_Stream\Connector->log, call_user_func_array, WP_MainWP_Stream\Log->log, WP_MainWP_Stream\DB->insert, WP_MainWP_Stream\DB_Driver_WPDB->insert_record

On live site error log is disabled where can i enable it?
On live site activating child reports plugin with the above problem also causes a conflict with UpdraftPlus

Warning: Your WordPress installation has a problem with outputting extra whitespace. This can corrupt backups that you download from here. Follow this link for more information

So on live site I deactivated the plugin child reports again for the time being.

Thanks for looking into this.
Suzan

Hi Suzan, thanks for the update.

Would you be able to send me temporary WP Admin access to the child site so I can check this further? If yes, please send it to me via private message.

Solved by @bogdan. Thanks for help.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.