MainWP Community

PHP errors on the dashboard

Hello,

I installed the 4.1 Beta Version of the MainWP Dashboard and I get these errors :

Deprecated: mainwp-activated is deprecated since version 4.0.7.2! Use mainwp_activated instead. in /home2/xxxxxx/public_html/wp-includes/functions.php on line 5148
Deprecated: mainwp-activated-check is deprecated since version 4.1! Use mainwp_activated_check instead. in /home2/xxxxxx/public_html/wp-includes/functions.php on line 5148
Deprecated: mainwp-extension-enabled-check is deprecated since version 4.1! Use mainwp_extension_enabled_check instead. in /home2/xxxxxx/public_html/wp-includes/functions.php on line 5148
Deprecated: mainwp-getextensions est obsolète depuis la version 4.0.7.2 ! Utilisez mainwp_getextensions à la place. in /home2/xxxxxx/public_html/wp-includes/functions.php on line 5148
Warning: Cannot modify header information - headers already sent by (output started at /home2/xxxxxx/public_html/wp-includes/functions.php:5148) in /home2/xxxxxx/public_html/wp-includes/functions.php on line 6270
Warning: Cannot modify header information - headers already sent by (output started at /home2/xxxxxx/public_html/wp-includes/functions.php:5148) in /home2/xxxxxx/public_html/wp-admin/includes/misc.php on line 1310
Warning: Cannot modify header information - headers already sent by (output started at /home2/xxxxxx/public_html/wp-includes/functions.php:5148) in /home2/xxxxxx/public_html/wp-admin/admin-header.php on line 9
Warning: Cannot modify header information - headers already sent by (output started at /home2/xxxxxx/public_html/wp-includes/functions.php:5148) in /home2/xxxxxx/public_html/wp-includes/option.php on line 1050
Warning: Cannot modify header information - headers already sent by (output started at /home2/xxxxxx/public_html/wp-includes/functions.php:5148) in /home2/xxxxxx/public_html/wp-includes/option.php on line 1051

Hi @CydZ, thanks for reporting this, I will have our dev team check this.

This sounds like an extension, that might not be supported anymore. Can you please check that?

I only have too other extensions :
MainWP Bulk Settings Manager Extension
MainWP Key Maker

I don’t use them myself, but I thought that Key Maker is not an Extension, but a plugin to use on child sites, so maybe that’s the one causing the issue. It’s always good to check if the errors disappear by deactivating extra plugins, so you know what elements are involved.

Thank you for your suggestion. I just disabled the plugin, but I still get the same PHP errors.

Can you please check do you have the DEBUG_LOG enabled on your setup?

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.