Subdomain plugin fails

I have installed (multiple times) MainWP Child plugin Version 4.1.6.1 on a subdomain (https://islandsmiles.bytique.com) running Wordpress Version 5.7.2. The plugin fails to activate (both in Installed Plugins and from WordPress.org/plugins) and MainWP Dashboard Version 4.1.6 does not recognize the MainWP Child site.

I have disabled all other plugins and cleared cache, uninstalled and re-installed the MainWP Child plugin without activation.

I have installed multiple MainWP Child plugins on other sites and had them recognized by MainWP Dashboard without problem.

Are subdomains accepted?

Thank you.

Hi @Randall,

Is there some error message that you get when the activation fails?

Thanks for asking! No. The plugin just does not activate.

The Dashboard cannot connect.

“MainWP Child Plugin not detected! Please make sure that the MainWP Child plugin is installed and activated on the child site. For additional help, contact the MainWP Support.”

Hi Randal,

Ok, can you tell me what response do you get if you run the test connection feature?

1 Like

Test: Connection successful!
URL: islandsmiles.bytique.com (IP: 173.201.186.141) - Received HTTP-code: 200 (OK)
Add Site: MainWP Child Plugin not detected! Please make sure that the MainWP Child plugin is installed and activated on the child site. For additional help, contact the MainWP Support.

I deleted the MainWP Child plugin. Searched wordpress.org and re-installed. It installs, but does not activate. I tried deactivating other plugins, deactivating MainWP Child, and then re-activating and/or reinstalling MainWP Child plugin. Same results: it installs but fails to activate, which cannot means it connect with MainWP dashboard.

Hi Randall,

Can you tell me what is the PHP version and PHP Memory Limit on the site where the child plugin fails to activate? Are you able to activate it if you deactivate all other plugins (temporarily)?

PHP Version 7.0.33, Memory should be the same as other WordPress installs on the same server, I have deactivated all other plugins with the same result.

Hi Randall,

Would you mind opening a private Help Desk ticket so we can collect some additional information & investigate further?