Support PHP 8.0

Hello,

I want to use PHP 8.0.

When do you start to support it?

Greetings

@DuerrSteidle

PHP 8.0 was release only 7 months ago - We still haven’t run full tests on PHP 8, so I would recommend keeping the MainWP server on PHP 7.x

PHP 8 is still pretty new and we will need more time to run tests before we can confirm full compatibility.

You may follow this thread here on the topic as well: PHP 8 Not work with MainWP - #6 by josklever

1 Like

Ok sorry for asking but I thought 7 months is a long time now.

When do you plan to implement it?

Hi DuerrSteidle,

We don’t have an exact time-frame, but we will give our best to handle it for the next bit release (4.2)

1 Like

Also, I want to stress that WordPress itself still doesn’t fully support PHP 8.

As per their records, PHP 8 is still “beta supported”.

In version 5.6, WordPress announced “beta support” and it’s still the same with the 5.8.

1 Like