Sync Dashboard with Child Sites spikes RAM

Appreciate the help… but I am not able to find within (WHM Root) anything related to cURL in EasyApache 4

The only settings my webhost has recommended changing relate to PHP-FPM

I am in search of a new webhost as this is driving me crazy. :frowning:

Looks like there isn’t settings just versions. This is what mine is running atm. Yur best bet might be switching hosting companies.


Thank you. Mine looks the same as yours.

I am researching hosting companies. I’ve tried (actually signed up and paid for accounts) with LiquidWeb and Cloudways and no way. Their setups are horrible compared to InMotion Hosting. :frowning:

I will keep looking for a replacement.

Update:
My current webserver uses PHP-FPM and if I disable it I don’t have the memory spike. In fact the memory only goes up 2-3% with PHP-FPM disabled and clicking the Sync button. With PHP-FPM enabled and clicking the Sync button my memory spikes big time.

I’ve disabled PHP-FPM and I am able to use MainWP normally again. I am happy its working because I rely on MainWP for lots of stuff.

I looked into a different web host but my current web host will not give me a refund and I have 7 months left on my current plan so I will stay with them for at least 6 more months then move to a new web host.

I learned a ton from all you trying to help me. THANK YOU! :slight_smile:

@RonTheWebGuy
I’m glad you were able to figure out finally what was causing the issue.
Thank you very much for following through and letting us all know what had happened so that others will benefit.

1 Like

Another quick follow up in case this will help others in the future… my web hosting company installed or massively changed nginx and PHP-FPM a while back. I “assume” this caused my issues all this time.

Over the last couple months of us trying to troubleshoot the memory used issues they suggested disabling PHP-FPM which I did. However: nginx (or at least the setup used at my webhosting company) re-enables PHP-FPM automatically.

The combination of nginx and PHP-FPM on my VPS made the Memory Used % a lot higher than without using nginx and PHP-FPM so I had them disable such. Now my Memory Used % idles around 28% vs. the previous 50%

And the best part is: when I click the MainWP Sync button the Memory Used % only goes up a few % points vs. 20-30 percentage points. :slight_smile:

Sorry for another post… I am just excited that this may finally be solved and I can get back to using MainWP fully again. :smile:

1 Like