Virusdie not syncing/updating

Hi,
What is the status on the Virusdie integration issues as reported here VirusDie not updating ?
I’m having the same problem with changes on MainWP not syncing with the Virusdie interface and the other way around as well (When I log in on Virusdie, it shows that the latest scan was July 17th, while on my Main WP dashboard it keeps saying June 17th, and my latest added sites aren’t added in Virusdie, even when uploading the sync file manually)

Thx!

1 Like

Hi @gleysen,

We are in touch with the VD team. We have a few users reported the same problem and we found that the problem comes from the VD API so we are working with them to resolve this.

As soon as it’s done, we will release update.

1 Like

Any info about that problem - still get only sync error Messages from Virusdie.

Hi Thomas, I am still working with the VD team on this. To be precise, I am waiting for the solution on their side.

3 Likes

@bogdan … just trying to keep this ticket open… any news yet?
(One of the main reasons I paid for a pro account is this Virusdie integration, and so far I’m not impressed with the lack of updates from MainWP, really hope we’ll see a solution soon!)

I am still in contact with the VD team. They are still searching for a solution.

After we went through our code multiple times, there are no errors on our side. The problem comes from their API and we have to wait for them. Unfortunately, there is nothing on our side that we can do to speed up the process.

As soon as I get more info from them I will update this thread.

1 Like

@gleysen there is nothing we can do if their API is causing the problem. You really should be directing your disappointment to their support team.

just keeping this ticket open …

Can you please check the beta4 version that we released last week and see if it makes any difference?
It should allow you to re-signin easier and we believe that could help.

Hi Bogdan
Just updated to beta4
I still just get ‘Unique sync file could not be uploaded. Please upload it manually.’ for the sites that could not be synced.
The file has been uploaded manually.
Removing the file and trying again makes no difference.

Hi Jakob,

this could be a server-side problem. Can you please verify with your host if there’s something that would prevent files to be uploaded?

In that case, you can manually upload the file and keep using the extension normally.

It’s the same with me, beta4 doesn’t fix it. I also have the problem message of the sync file not able to upload… it’s not something with my host, because in the beginning when I added the first websites, it worked ok and all my sites use the same hosting environment.
Uploading the sync file manually doesn’t help either, same error message.
Not sure if this could help, but I thought that problems occurred when I logged into Virusdie directly on their website, to see if they showed more details… but not sure about that.
Also when I open the settings for the virusdie extension, it shows “Virusdie API Connected successfully.” but then when I click on “Reload Virusdie Data” it shows the error “API could not be connected. Please try again or contact support.”

Unfortunately

and it makes no difference.

I logged in to my virusdie dashboard on virusdie site itself, and have 2 website there that aren’t synced.
So I send a support question to Virusdie directly to see if they can see why those 2 sites aren’t syncing since they both have the sync file uploaded… and hopefully if I can get that fixed, it will fix my issues on MainWP as well… I’ll keep everyone posted here when I hear back from Virusdie!

@bogdan Is there a way to retrieve my Virusdie account password to see if it’s the same as what I use to login into the virusdie site directly?
Because I tried to remove one of my site from the virusdie dashboard in mainwp and I got this error:
image
Then after the message, the details of the virusdie scans is gone from the dashboard (so it looks like it’s not connected to virusdie anymore) however on the virusdie site , those ‘removed’ websites are still listed.
If I click on “log out” in the settings, it says I would need to sign up again to get a one-time password… so I haven’t tried that, since I don’t want to be locked out completely… so would that be ok? And what happens with me existing login then? (I want to keep the same email address for my virusdie account)

Thx!

@webink @ThBunte … do any of you use Ezoic on your websites that don’t sync?
In my support ticket with Virusdie, it came up that my server response had some extra HTML code wrapped around it that prevented Virusdie from parsing the result. And it seems that it’s caused by Ezoic, that I use for advertising. … but haven’t found a final solution though, still in contact with both their support teams.
But it would be interesting if you both use Ezoic as well! … so let me know!

Nope. I don’t use Ezoic (or other ad-service) on the sites that I trouble with.

We also do not have Ezoic in use on any website.

All… FYI, Virusdie moved to Amazon AWS last night… and all of a sudden the sync started working, despite my Ezoic settings… so I do think that had something to do with the Virusdie servers…

Anyway… my Main WP sync wasn’t solved, that still gave the same errors…
So what I did was, I logged Out! … that meant I needed to create a new login with a one-time password, so I used a different email address… and after I logged in with the new one-time password, the API gave all green messages! And everything seems to be ok! (no scans have been done, but I’m optimistic!)

So perhaps the failing of the initial account was perhaps linked to the fact that I used it to login directly on the Virusdie website? Could that be?
I’ll recheck the sync settings after a few days, to see if scans are happening, and I won’t use the one-time password to login to Virusdie website directly! Hope this helps the others here as well…

Tried the same, but now I’m just logged out for good :frowning:

“Sign-in failed. Please try again or contact support.
Due to limitations in Virusdie’s API, existing accounts created without using the MainWP Virusdie Extension do not have the required permissions to manage connected sites.”