What are your WPVivid settings for various hosts?

I’m trying WPVivid to replace UpdraftPlus.
I must say the experience has been terrible so far. The very first site I installed it on, failed the backup. I went digging into settings and managed to get it to go through after adjusting things. This was just a small site.

Since then, every site fails to backup after installing. It pretty much doesn’t even work out of the box.
Now I change all the default settings to help it not crash and timeout and use up all its retries, etc.

I backup to Amazon S3, and usually when the backup works, this also works. But here too some backups will just fail with an S3 error of some kind.

WPVivid has this odd desire to fail and cancel at the nearest opportunity. Some timeout, after some retry, some memory thing, some S3 problem, kills the backup. I don’t care if the backup takes 3 hours, it needs to just keep retrying and get the job done.

There are only so many settings in here. I set higher and lower timeout periods, higher and lower splitting numbers, optimization, no compression, etc etc.

Just today I wasted half the day with three different sites on three different hosts, and none of their darn backups will actually make it all the way through!

I figure I’m not the only one who deals with this, so I’m wondering how you set your settings to make it work.
Most of the hosts I work with are common shared hosts like SiteGround, WPEngine, InMotion Hosting, Bluehost, and some LiquidWeb in there too. Sites can be anywhere from a few hundred megs in size to many gigs.

I need a backup tool that is robust, and doesn’t give up so easily. UpdraftPlus, for all its faults, just worked out of the box and managed to get sites backed up. If it didn’t work, I just lowered the zip file split size and it was good. Vivid I just can’t seem to find the right settings so it will finish a backup.
I don’t know why it is that Updraft was able to do 500MB compressed zips just fine, but Vivid can’t finish a backup even when I set it to 50MB and a long timeout.

I’ve emailed 15 failed backup logs to them trying to find a solution.

I just wanted to know if anybody else has this kind of trouble using Vivid and what settings work best for them, cause I’m about to switch back to Updraft.

1 Like

Still nothing but problems since the last post.

Now when I finally manage to get backups to actually work, I’ll sometimes get S3 issues, causing the backup to give up. It’ll just say “internet error” or a few others. It may upload some files but not all of them.

I don’t know if I’m going crazy but this program has about 1 successful backup to 30 failures. I have no idea why it came so highly recommended. I had high hopes but I’m about to give up. Wasting three days trying to set it up on my retainer sites and the only ones where it works well are the tiny no-traffic websites that are only a few hundred MBs in size. It utterly fails at larger sites.
It’ll create a 10GB backup set and begin uploading to S3 but if it comes across one single error message back from S3, the whole thing gets cancelled, backup is deleted, total failure. It’s like Vivid is desperate to cancel and erase your backups, does it even retry?

This has been a terrible experience, not even sure I can get a refund at this point. Highly NOT recommended, sadly.

Hi Zack
I’ve been using this since it came out, mainly because they had a MainWP plugin too, and I have 40 plus site backing up to S3 every day, never had a problem?
At least one site has Gbs sized DB, I’ll admit I only do scheduled DB backups, but when I do whole site manual to S3 it’s fine too.
I’ll set up a scheduled S3 full backup on a couple of sites to see if I get the same, other than that I really like the plugin, the backup before updates (on site) is nice safety net!
I’ll get back to you.
David
PS I’m not associated with Vivid in anyway, I just like it :slight_smile:

Glad it works for somebody, but definitely doesn’t work for me.

Sites on multiple hosting plans on InMotion, dreamhost, bluehost, wpengine, and siteground.

I’ve changed settings till the cows come home but most backups fail, usually just saying timeout. And I’ve seen 3 different S3 errors cause it to break as well.

I don’t think anything out of the ordinary is part of my setup. All my sites will have common plugins like MainWP, Sucuri, backup plugin, limit login, analytics, etc. Don’t think those are causing anything, as sometimes I can get backups to work.

I’ve set the timeout (in Vivid) from 30 seconds to 10800 seconds, and zip files from 50MB (minimum) to 400MB. Turned on/off optimizing, and other time consuming activity, turn off compression, etc.

Three days of not being able to get any backups done consistently, I have to switch back to Updraft, no choice at this point.

Are you sure your backups are actually succeeding? Do you check the log files and make sure every file is uploaded to S3? I had some cases where not all the files got uploaded to S3.