[wordfence.scan.count] not working in Client reports

Hello,

I just noticed that the [wordfence.scan.count] option in my Clients Reports extension is showing 0 scans for all my sites, which is not correct for sure.

I have the free version of Wordfence which scans my sites once every 3 days. I checked in the Wordfence logs that the scans where indeed performed.

But they do not show up in the [wordfence.scan.count] part of my Client Reports.

Did you put this in the section ‘loop’ like this?

[section.wordfence.scan]
[wordfence.scan.count]
[/section.wordfence.scan]

In the Report body I put it like this:

Security scans: [wordfence.scan.count]

This worked fine before…

When I select this period: 01/06/2021 - 07/07/2021

I see 2 scans in my report: the last one at 6 june, after that the new scans are not counted anymore. This is the same for all my child sites.

Perhaps something has changed but could you try it, just to humor me :wink:

[section.wordfence.scan]
Security scans: [wordfence.scan.count]
[/section.wordfence.scan]

I have used that code already, but still only 2 scans are counted, it stopped counting on 6 juni…

I have sent myself a client report for the month May and I see 10 scans in that report, which is correct.

So there really seems to be a problem with this started after the 6 juni

Ah I see… Definitely a date range issue not a syntax one. Not sure how to resolve this… hopefully some of the devs can chime in.

Yes, let’s wait for them :slight_smile:

Rick, do you use the Client Report extension yourself, or the Pro Report extension?

Neither… I find the reports very limited for my needs and cumbersome to make a nice report layout (sorry devs :wink: )

I find that my clients really don’t care about how many times plugins or themes were updated this month. They understand updates.

But we should inform them about how many attacks where blocked (like bruteforce/login attempts, SQLi etc.) Because they have no idea what is happening and need to be informed/educated why it’s important to have us maintaining and protecting their sites.

The reports, at this moment, do not tell the whole story… nor sell it.

1 Like

Hi Alwin,

Do you get this problem for all your child sites or just one/few?

Also, the “count” tokens should not be used inside the section tokens.

Hello Bogdan,

Yes, on all my child sites!

This is how I have the code in the Overview section in the report:

Security scans: [wordfence.scan.count]

This worked before but scans performed after 6 Juni are not counted anymore.

Further down in my report I have this code:

[section.wordfence.scan]
[wordfence.scan.date][wordfence.scan.result]
[/section.wordfence.scan]

Only scans until 6 Juni are showing here too.

Hello Bogdan,

Any update on this?

Thanks!
Alwin

Hi Alwin,

Would you mind opening a private Help Desk ticket so we can collect some additional information & investigate further?

Hello Bogdan,

I already sent a (private) email to [email protected] yesterday :slight_smile:

1 Like

Thanks Alwin. We will give our best to resolve the problems as soon as possible.