MainWP Community

WP Security Audit Log version incompatibility w/ new v4.0 plugin

Hi,

WP Security Audit Log have just released their v4.0 plugin, but they haven’t updated their MainWP plugin which is still at v1.3… and we get an error message in the MainWP interface : " *The WP Security Audit Log plugin installed on the below child websites is version 4. Please update this extension to version 4 to download the logs from these websites.

I realize this isn’t MainWP’s problem in terms of releasing a new version, but has anyone heard if/when the MainWP plugin will be refreshed from WPSAL ?

3 Likes

Hi, I will bring attention on this to WPSAL’s Author, Robert Abela.
Thx!

4 Likes

Hello everyone,

We are aware of this. Our plan was to release the MainWP extension update together WP Security Audit Log version 4. However, we encountered some issues.

We are currently working on the MainWP extension and the new update, which is of course compatible with V4 should be available no later than next Wednesday.

I am really sorry for the inconvenience this might have caused. Should you have any other questions do not hesitate to contact us on support@wpwhitesecurity.com

Thank you for using our plugin.

6 Likes

Thx Robert, those are great news! :wink:

It does not even get activated on child site. I get locked out ERR_TOO_MANY_REDIRECTS

Had manually deactivated it through sftp to gain access again

Hi Robert,

So we’ve updated, but on our MainWP dashboard, we get the “eternal spinner”. The only site showing is the MainWP Dashboard’s logs :frowning:

I’ve ensured the child sites have the new version of the plugin, to no avail.

Hello Jean-Francois,

You were a bit unlucky. The first time you reported the issue it was because of WP Security Audit Log v4. We released a fix for that but in the meantime MainWP released an update a few days ago that broke something in our plugin.

We just released (10 minutes ago) an update that fixes this. Please update the MainWP extension to version 1.4.1 and everything should work.

Sorry for the inconvenience and thank your for your patience.

1 Like

Hi Robert… me again, pestering you.

So we’ve installed 1.4.1… now, there’s no spinner, but also no results.
And I know the test site well, as it’s my own. EVERYTHING is up to date

And the WPSAL still only shows updates on the MainWP install, none of the child sites come through.

Is there a DEBUG functionality I can active on your plugin to help troubleshoot this ?

I also notice than when in MainWP, going in my site’s profile, and trying to click on the “Activity Log” Menu, it never reaches the page /wp-admin/admin.php?page=ManageSitesActivityLog&id=1, and in the Chrome console, complains about net::ERR_HTTP2_PROTOCOL_ERROR 200

Don’t worry Jean-Francois, you are not pestering me. It is our job to give you a good working product.

Can we please switch to email so we can share more details, including screenshots etc and hopefully nail this issue? Please email us on support@wpwhitesecurity.com and mention this ticket.

Looking forward to hearing from you and thank you for your cooperation.

3 Likes

I was experiencing similar issues as Jean-Francois. Updating to 1.4.1 turned out to be the solution.
Big thanks to Robert!

3 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.