MainWP Community

Connection test failed - Received HTTP-code: 404

Hi!

I can’t connect with one on my sites.
I went to Sites > Add new and filled in all the data including unique security id.

The thing is this Wordpress site is on subdomain (fakestore.testelka.pl) and is on a different server than the main domain. Both sites works fine in the browser. But then when I try to add the page on the subdomain I’m getting an error:
Connection test failed.

URL: fakestore.testelka.pl (IP: <ip_of_testelka.pl_not_fakestore.testelka.pl) - Received HTTP-code: 404 (Not Found)

So it looks like somehow MainWP considers fakestore to be on the same server as testelka.pl which is not true. DNS is set up throgh Cloudflare. Any ideas why is that and what can I do?

Can you test turning Cloudflare to just pass through and run the test connection again. Once you have done that can you confirm the IP being returned in your test connection matches the actual IP of fakestore.

This will show us if your Dashboard is reaching the correct server and we can keep testing from there.

Hi!

If this is what you mean:


Then it changes nothing - still getting IP for testelka.pl

That’s correct,

Now if you go to WP fakestore > Settings > MainWP Child > Server Information page you can verify the child site IP does it match what you see if you check it here https://dnschecker.org/#A/

Edit: Just to add more information, what we’re trying to figure out is exactly where the issue is. Is your Dashboard host DNS not updated to reach the new site, has the new site not properly propagated or some other issue. Note: The plugin is only reporting what it gets from the Dashboard Server and can’t make changes to what it finds it’s self.

OK, so after doing what you suggested IP address from dns checker matches what I can see in MainWP Child for fakestore.testelka.pl. Still, testing connection in the MainWP throws 404 and wrong ip address.

That shows us that the issue is with your Dashboard host, you’ll want to contact your Dashboard host support to clear the DNS Cache in order to connect.

3 Likes

Ok, I’ll do that, thanks!

3 Likes

Was @dennis’s suggestion helpful - are you still in need of assistance on this issue?

Yes, it’s working now, thank you guys!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.