MainWP Community

Extension Updates

While debugging the Branding Extension issue with jQuery i realized there was a new version available (new 4.0.2, installed 4.0.1) but the update was not shown under the installed plugins. Even a click on the check for updates button did not show an update. I had to deactivate the license and reactivate it. Then i had to check for the update again to show the available update.

We had this issue in the past (support ticket 45773) and it was expected to not return. Because this now happened on an other MainWP Dashboard i assume the issue may be caused by two or more Installations using the same extensions because now under API Keys i see:

site1.com activated on Sep 9, 2020 at 03:57 am
site2.com activated on May 18, 2020 at 07:21 am
site1.com activated on Sep 28, 2019 at 06:13 am

Please fix this API Key bug asap. It is fatal if the system used to keep wordpress sites updated itself is outdated and you cant see it.

Hi @mensmaximus, thanks for reaching out.

I checked your account and I assure you that everything is set properly on our side.

However, the issue that you experience can happen sometimes when the extension activation status gets “stuck” on your setup. It can happen for multiple reasons, but solution is simple:

  1. Go to the WP > Plugins > Installed Plugins page
  2. Deactivate all MainWP Extensions
  3. Reactivate all MainWP Extensions
  4. Go to the MainWP > Extensions page
  5. Click the Activate Extenions button
  6. After the extensions are activated, go back to the WP > Plugins > Installed Plugins page
  7. Check for the new updates

Hi Bogdan,

thank you for the ‘work around’. However this is no solution. You cant expect a user to deactivate and activate all extensions every day to see whether there are updates or not because your extension activation status may get stuck. Please tell the development team to fix the issue and to implement a stable and reasonable update solution. As from my other thread we now know this happens not only to me.

Regards

Michael

1 Like

Hi Michael,

Thanks for getting back to me. I know this is not a perfect solution, but as I mentioned earlier, this is not an issue caused by a bug in the code. It’s a problem that occurs when the API activation status gets messed up somehow on the dashboard installation. Usually, when this happens and API gets reactivated, this issue should not happen again unless something chagnes in account or API status gets corrupted again.

@bogdan, I have the same issue. For The Custom Dashboard plugin, I didn’t get any notification. I had to download manually from MainWP account and upload to the site…

My apologies for the inconvenience. Please try the steps as I suggested and if that doesn’t help, please open a ticket so I can look into your account to be 100% sure that everything is set properly on our side.

@bogdan - followed the instruction and lost all extensions!!! https://a.cl.ly/yAubRmrn - I can’t reactive them… :frowning:
HELP!
EDITED: I checked my login information and I got a message: “Login information Valid”.

Fred, don’t worry, even without API license extensions are fully functional.

Can you send me temporary access to your dashboard to check this (via PM)

Just the quick update that the problem is resolved for Fred. API licenses got invalid due to email change. Old email address was still assigned to API license Email

2 Likes

I have the same issue with the updates not appearing. I have a ticket open since it has been an ongoing issue.

@bogdan

I’m sorry but I have to contradict you. It is for sure an issue with the mainwp dashboard code.

Your development has decided to use a custom code for licensing and checking updates. The code is simply unreliable if the logic behind that code can cause updates not be announced.

When you say the api issue should not appear again if nothing has changed on the site hosting the mainwp dashboard, I have to tell you different. Just two days ago I followed your advice from your first reply to fix the issue on my installation. Today i get announced the many updates for extensions on my second installation but not on the installation I have ‘fixed’.

You know I develop plugins myself and maintain my extension for mainwp. I have questioned mainwp’s way to integrate extensions from day one. However, as long as it works I don’t mind. But if it comes to an issue like with updates I have to raise my voice. And as we learned within only two days there are other users experiencing the same issue.

@bogdan I really like mainwp, I appreciate your support and I communicate this as often as possible. But the issue with extension updates is the sole problem of mainwp’s code. Nothing else. Simple as that.

Best regards

Michael