MainWP Community

Getting 'error' for new site: HTTP-code: 200 (OK) - Error message: Invalid host

Hi!

I’ve been using mainwp for several sites and it works perfectly. Now I have a new site, which is hosted at a DIFFERENT web hosting server and now I get this error message when I test the site:

HTTP-code: 200 (OK) - Error message: Invalid host.

I cannot seem to figure out what is wrong. The host I use is 100% correct (e.g. when I use www.google.com it will give a 404 in stead of 200), but it still doesn’t work.

When looking into the access log of the child website I see the following:

185.94.230.89 - - [21/Nov/2020:13:02:20 +0100] "POST / HTTP/2" 200 129687 "http://mainwp.website" "Mozilla/5.0 (compatible; MainWP/4.1.2.1; +http://mainwp.com)"
185.94.230.89 - - [21/Nov/2020:13:02:21 +0100] "POST /wp-admin/ HTTP/2" 302 0 "http://mainwp.website" "Mozilla/5.0 (compatible; MainWP/4.1.2.1; +http://mainwp.com)"
185.94.230.89 - - [21/Nov/2020:13:02:21 +0100] "GET /wp-login.php?redirect_to=https%3A%2F%2Fchildwp.website%2Fwp-admin%2F&reauth=1 HTTP/2" 200 8340 "http://mainwp.website" "Mozilla/5.0 (compatible; MainWP/4.1.2.1; +http://mainwp.com)"

I have changed the mainwp url to mainwp.website and the childwp url to childwp.website in this post.

There is nothing in the error log on the host of the child website.

I’m not sure if this is correct and if someone can see something wrong in this.

Here’s the server report for the main website:


### Server Info                    Required                                               Detected                                     Status   ###

MainWP Dashboard                   
MainWP Dashboard Version           4.1.2.1                                                4.1.2.1                                      Pass        
MainWP Upload Directory            Writable                                               Writable                                     Pass        
MainWP Extensions                  
No installed extensions            
WordPress                          
WordPress Version                  >=3.6                                                  5.5.3                                        Pass        
WordPress Memory Limit             >=64M                                                  40M                                          Warning     
MultiSite Disabled                 =true                                                  true                                         Pass        
FileSystem Method                  = direct                                               direct                                       Pass        
PHP                                
PHP Version                        >=5.6                                                  7.4.12                                       Pass        
PHP Safe Mode Disabled             =true                                                  true                                         Pass        
PHP Max Execution Time             >=30 seconds                                           30                                           Pass        
PHP Max Input Time                 >=30 seconds                                           -1                                           Pass        
PHP Memory Limit                   >=128M                                                 256M                                         Pass        
PCRE Backtracking Limit            >=10000                                                1000000                                      Pass        
PHP Upload Max Filesize            >=2M                                                   2M                                           Pass        
PHP Post Max Size                  >=2M                                                   8M                                           Pass        
SSL Extension Enabled              =true                                                  true                                         Pass        
SSL Warnings                       = empty                                                error:2006D080:BIO routines:BIO_new_file:no such fileWarning     
cURL Extension Enabled             =true                                                  true                                         Pass        
cURL Timeout                       >=300 seconds                                          60                                           Warning     
cURL Version                       >=7.18.1                                               7.71.0                                       Pass        
cURL SSL Version                   >=OpenSSL/0.9.8l                                       OpenSSL/1.1.1d                               Pass        
PHP Allow URL fopen                YES                                                    
PHP Exif Support                   YES ( V7.4.)                                           
PHP IPTC Support                   YES                                                    
PHP XML Support                    YES                                                    
PHP Disabled Functions             No functions disabled.                                 
PHP Loaded Extensions              Core, PDO, PDO_ODBC, Phar, Reflection, SPL, SimpleXML, bcmath, bz2, calendar, ctype, curl, date, dba, dom, enchant, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imap, intl, json, ldap, libxml, litespeed, mbstring, mysqli, mysqlnd, odbc, openssl, pcntl, pcre, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, posix, pspell, readline, session, shmop, snmp, soap, sockets, sqlite3, standard, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib
MySQL                              
MySQL Version                      >=5.0                                                  10.3.27-MariaDB                              Pass        
MySQL Mode                         NO_ENGINE_SUBSTITUTION                                 
MySQL Client Encoding              utf8mb4                                                
Server Info                        
Server Software                    Apache                                                 
Operating System                   Linux                                                  
Architecture                       64		 bit                                               
Server Protocol                    HTTP/1.1                                               
HTTPS                              OFF                                                    
Server self connect                Response Test O.K.                                     
User Agent                         Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.198 Safari/537.36 Edg/86.0.622.69
Gateway Interface                                                                         
Memory Usage                       32.18 MB                                               
Request Time                       1605960840                                             
Accept Content                     text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
Accept-Charset Content             N/A                                                    
MainWP Settings                    
Number Of Child Sites              3                                                      
Use WP-Cron                        Yes                                                    
Optimize for Shared Hosting or Big NetworksNo                                                     
Automatic Daily Update             Install trusted updates                                
Abandoned Plugins/Themes Tolerance 365                                                    
Maximum number of posts to return                                                         
Maximum number of pages to return                                                         
Primary Backup System              Default MainWP Backups                                 
Maximum simultaneous requests      4                                                      
Minimum delay between requests     200                                                    
Maximum simultaneous requests per ip1                                                      
Minimum delay between requests to the same ip1000                                                   
Maximum simultaneous sync requests                                                        
Minimum simultaneous install/update requests                                                       
Active Plugins                     
Duplicator                         1.3.40                                                 Active                                       
MainWP Dashboard                   4.1.2.1                                                Active                                       

Thanks for reading and I hope someone can help me figure out what is wrong!

Thanks in advance.

Hi @Toverbal,

thanks for reaching out.

You mentioned that you get this response from the test connection:

HTTP-code: 200 (OK) - Error message: Invalid host.

However, what error message do you get when you actually try to connect the site?

Hi @bogdan, thanks for your reply. If you mean what message I get when trying to add the site in stead of testing, it shows the following message:

I’m not sure how to proceed, it’s not really descriptive :slight_smile:

Hi @Toverbal, thanks for the update

I see that there is an OpenSSL misconfiguration on your dashboard server. Notice this SSL Warning:

error:2006D080:BIO routines:BIO_new_file:no such file

Has your MainWP Dashboard been hosted on localhost or web-hosted Win server before the current location?

Hi @bogdan,

Thanks for your answer. The MainWP dashboard host not been changed, but there are already 3 websites connected to the dashboard. All these 3 websites are hosted on the same server as the dashboard, but I add them with the URL, not with localhost.

The site I wish to add now is hosted on a different server than the MainWP dashboard. So it is probably somwething on the server of the MainWP child I’m trying to add, but I don’t see any errors or anything like that :slight_smile:

I hope you can think of something I can try to clarify the error :slight_smile:

Thanks in advance.

Hi @Toverbal,

Thanks for getting back to me.

Would you be able to send me temporary login to your MainWP Dashboard (via Private Message) so I can check this further?