MainWP Community

Issue with MainWP & IIS

Hi, we have installed mainwp on php 7.3.3 and IIS (I know, it’s bad). I tried to hook up sites but if fails with lots of 404 & 500 errors all related to Ajax…
(for example :
DataTables warning: table id=mainwp-manage-sites-table – Ajax error. For more information about this error, please see http://datatables.net/tn/7)
When I compare with my other install (on Ubuntu) I see for example that I do not see my IP address on the admin.php?page=ServerInformation page…
has anyone experienced issues with IIS and PHP ?
(My wordpress sites work well apart from this)

1 Like

Hi @jgcabanas, it might be best if you could open a helpdesk ticket so we can look into this. Would that be ok?

Hi @jgcabanas, regarding the Ajax error, you may also want to try to disable all plugins on your MainWP Dashboard site and keep just the MainWP Dashbaord enabled. This could be caused by some plugin conflict.

Hi, thank you for your suggestion but mainwp is already the ONLY plugin :confused:
(I have seen this before posting).

Yes of course.
I will open a ticket asap

1 Like

Just to tell everyone who might have the same problem, that on my side it was due to a misconfiguration in php.ini regarding to openssl.cnf.
After digging with MainWP support team (great guys and great help) I realized that openssl.cnf was in c:\Programmes\php\extras\ssl BUT phpinfo() told me it was in c:\usr\local\ssl so I created this hierarchy, copied openssl.cnf, and now it works. Thank you so much MainWP support team for pointing me in the right direction :slightly_smiling_face:

3 Likes

Hi @jgcabana, thanks for sharing your solution. I am sure it will help other users that stumble upon this problem.