Plugin blocking bulk upload nonce

Hi all, I’m going to pass this to the plugin dev too, but thought I’d ask here if anyone had ideas.

I’ve imported from key maker settings to update the WP Mail SMTP plugin settings - however when I try to save to a site I get the message

Trace: #0 wp_verify_nonce() called at [/var/www/XXXXXXX.uk/wp-content/plugins/the-events-calendar/src/Tribe/Admin/Timezone_Settings.php:70] #1 Tribe__Events__Admin__Timezone_Settings->listen() called at...(truncated)

I’m updating settings in WP Mail SMTP, however it seems the Events Calendar plugin is intercepting this. I’ve confirmed that plugin seems to be at fault, as when disabled settings are deployed correctly.

Is it something I’m missing in the setup? The Key.URL is set to wp-admin/admin.php?page=wp-mail-smtp which is the correct page on the site…

Thoughts?

Thanks

Paul

Hi Paul,

Thanks for reaching out.

Can you tell me is that the whole error? Can you please post a screenshot of the screen where you see this error so I can understand it a bit better?

Hi Bogdan, thanks for the reply. Error attached.

This happens when I go to Bulk Settings Manager and select the single key site.email.SendgridAPI1 which should be setting the WP MAIL SMTP plugin settings for using Sendgrid.

Looks like the call is being intercepted by The Events Calendar plugin (shown in the error message). If I disable the plugin it sets the configuration correctly.

Thanks

Paul

EDIT: I have just tested this with settings for Yoast too, with the same error and it works if the TEC plugin is disabled.  I am pretty sure this is an issue with that plugin and I will raise with the devs for it, but if you can provide me with a steer of what I should be telling them, that would help!  Thanks

Hi Paul,

Yes, it looks like a conflict created by the TEC plugin.

Let’s see what the plugin authors have to say about it.

Thanks!