Plugin update issues

Hey, we just set up MainWP for some of our websites. We are noticing some odd things happening while trying to update plugins. Sometimes when we update a plugin (no matter which tab we are on - Updates, Plugins, or Sites) and then refresh the page, it will suddenly not display the remaining available updates. Sometimes this happens for just one website, other times it has happened for multiple sites. When we click the Sync button, the plugin updates show back up. So basically, every time we want to update just a single plugin, we need to click the Sync button after each update.

Here are some videos below showing this. The first one shows that the Elementor Pro update is all of a sudden missing after we do an update for a different plugin. The second video shows that 2 sites suddenly don’t show any available updates after updating a single plugin and doing a refresh. When clicking the Sync button, they show back up.

https://sharing.clickup.com/clip/p/t8686616/5e775429-c508-47cd-bbec-42d68d7eb2b3/screen-recording-2021-06-08-12:42.webm

https://sharing.clickup.com/clip/p/t8686616/80eb1fa0-b8f9-4342-9ec6-a9896a05774c/screen-recording-2021-06-08-12:40.webm

Any idea what could be causing this?

Can you please post the community system report from your MainWP Dashboard for review? The report is located in your Dashboard under Status → Server, on the top right of the page.

Be sure to use the button like the one below; this button hides all your private information:

image

Pressing the button auto-copies the report to your clipboard then just paste it in a reply here.